
 

 

Page | 1 
WORKING IN THE VIRTUAL WORLD - North Coast TAFE 

 

Instructions 
 

WORKING IN THE VIRTUAL WORLD 
 

Virtually Hyperconnected Project 2013 

North Coast TAFE  
 



 

 

Page | 2 
WORKING IN THE VIRTUAL WORLD - North Coast TAFE 

 

© Copyright, 2013 by TAFE NSW - North Coast Institute 
 

Date last saved: 12 April 2013 by Miller, Alexandra Version: 3.12 # of Pages = 12 

 
Acknowledgements: The Virtually Enterprising Project 2012 was funded by The National 
VET eLearning Strategy, Australia with co-contributions by North Coast Institute of TAFE 
and Virtual Enterprise Australia. 

Virtual World created by Jo Kay (http://www.jokaydiagrid.com/). 

Disclaimer: In compiling the information contained within, and accessed through, this 
document ("Information") DEC has used its best endeavours to ensure that the 
Information is correct and current at the time of publication but takes no responsibility for 
any error, omission or defect therein. To the extent permitted by law, DET and its 
employees, agents and consultants exclude all liability for any loss or damage (including 
indirect, special or consequential loss or damage) arising from the use of, or reliance on, 
the Information whether or not caused by any negligent act or omission. If any law 
prohibits the exclusion of such liability, DET limits its liability to the extent permitted by 
law, to the re-supply of the Information.  

Third party sites/links disclaimer: This document may contain website contains links to 
third party sites. DEC is not responsible for the condition or the content of those sites as 
they are not under DEC's control. The link(s) are provided solely for your convenience and 
do not indicate, expressly or impliedly, any endorsement of the site(s) or the products or 
services provided there. You access those sites and use their products and services solely 
at your own risk. 
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Building and creating 

I. Putting items into your inventory 
To ‘buy’ items for your booth, go to the Supply/Storage area and locate items you wish to 
use. 

1. Right-click on an item and select ‘Buy’ from the function wheel. 

2. When the ‘Buy a copy of’ dialogue box appears, click ‘Buy’ again. 

  
3. A copy of the item will be placed in your Inventory.  

Note: The inventory works a lot like Windows Explorer, you can create folders, copy 
files, etc using the usual file management techniques. 

II. Placing your furniture in your booth 
Firstly, make your way to the Trade Fair area where the booths are to be set up. 

1. Open your Inventory. Locate the object you want to place in your booth. 

2. Select the item in the inventory by clicking on it with your left mouse and dragging 
it onto the floor in front of you 

 

1 

2 
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3. If the item ‘sticks’ to you, open your Inventory, locate the item, right click on the 
item in your Inventory and select ‘Detach from yourself’. 

 
Note: If you object is upside down, you will need to rotate it (see below) 

III. How to rotate your object  
1. Right click on the object and select Edit, a build menu will appear  

 
2. In the ‘Build’ menu select the Edit tab (center tab) and then choose Rotate. 

 
3. Your object will now show rotation lines (as above), click and drag along the axis 

the way in which you intend to rotate the object (see below) 

 

1 
2 

Clicking the blue line will 
allow you to rotate along 
that line (as below) 

Note: You can deactivate 
this by clicking anywhere 
on the screen. 
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IV. How to reposition your object 
1. Right click on the object and select Edit, a build menu will appear (you can also 

click the build button at the bottom of the screen) 

2. In the ‘Build’ menu select the Edit tab (center tab) and then choose position, 
directional arrows will appear 

 
3. Click the red arrows to move horizontally, etc 

 
Note: If you have difficulty moving the object, use your Camera Tools (View > Camera 
Controls) to pan out a bit and drag the object from a distance instead. 

V. How to give someone else your object 
Open you Inventory, locate the item and drag & drop it onto your colleague’s avatar (to 
select and drag it, use your left mouse button).  

This works with most items in your inventory, i.e.  objects, scripts, sounds, textures, 
landmarks,  items of clothing, etc 

Clicking the red line will 
allow you to position/ 
move the object in that 
direction 
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Display boards 

VI. How to upload a graphic for a display board 
You need to upload an image to use on your display board. You can do this by  

1. Go to File > Upload > Upload Image 

 
2. Browse to the location of the .PNG file and double click on it to upload it 

3. Once uploaded you can retrieve it from your Inventory (it will be in your textures 
folder) 

VII. How to make a graphic for a display board 
Here is a quick way to create an image. 

1. Create your image in PPT - this could be an image, text, or a combination (in PPT 
you can ‘group’ objects, right click and and save them as one file).  

2. Save the file to your computer as a .PNG image file. 

VIII. How to put a graphic on your display board 
Some of your objects (such as the display boards) are made up of more than one ‘part’ (ie: 
a display board has a backboard, and a display or ‘white’ board). To put a graphic on your 
display board follow these steps: 

Part one – selecting the area to add your graphic 

1. Place the customisable easel/ displayboard where you want to place it (rotate and 
reposition as above)  

2. Select the the parts (or ‘Primitives’) that you want to ‘texture’ (put a graphic on) 

3. Right click on the object and select Edit  
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4. On the Build menu, choose the Edit tab (if it’s not already showing) and select 
‘Select faces to texture’. This action will slect ALL the parts of the object. 

 

5. Click on the white part of the display board to select just that part of the board. 

  

Part two – adding your graphic 

6. With the center tab (Edit) on your Build menu selected, click on the Texture tab 
(halfway down the Build menu) and click on the blank ‘texture’ field. 

 
7. In the Pick Texture box, you can select a texture directly from your Inventory and 

click the Select button. Alternatively, you can click and drag it directly from your 
inventory onto the texture picker (see below) 

1 
2 

1 

2 
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8. It will shortly appear on your display board 

IX. How to animate your graphic 
To be able to do this you need an animation script. Check your Inventory for this – if you 
don’t have one, speak to your facilitator or check the OpenSim Library. The URLGIVER 
script will allow you to put a link to a website on your image. 

1. Open your Inventory > Scripts and check that you have an animation script. 

 
2. Right click on the display part of the object you need to apply the texture to and 

select Edit 

3. Click the Content Tab 

 
4. With your Inventory open and animate script showing, drag the script into the 

contents folder (see below) 

1 

2 
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5. Drag and drop your Animate script from your Inventory over to the Contents area 

in the Build menu. 

X. How to add a script with a URL 
URLGIVER script will allow you to put a link to a website onto an object, i.e. The image/ 
texture on yoru display board. Here’s how: 

1. Double click the URLGIVER script in your inventory 

2. Replace the “Add your title here” with the name of the website or an appriopriate 
message to the user who clicks on it, i.e. “Visit North Coast TAFE online” 

3. Replace the web address with your website address 

4. Click Save 

 

Important! 
Please clean up after yourself (particularly in the Conference/ Trade Fair Center) by using 
one of the following options: 

• Right click object and select ‘Take’ 

• Right click object and select More > Delete 
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Brochures 
In the training centre there’s a workroom where you’ll find rows of work benches with 
some preset brochure templates. You can make a copy of these templates (buy a brochure 
kit) and use them to recreate your own brochures. 

 
A few things you need to know first. 

1. The posters on the wall in the screen shot above are a poster version of the 
brochure templates lying on the tables. Nothing can be done with them. 

2. Giver –  The brochures on the table are called ‘givers’. Givers are items that 
avatars can buy (even for $0) and of course, they will go into their inventory. 
Conversely, a booth visitor could ‘buy’ the folded brochure and place it in their 
Inventory to look at later. 

3. URL Giver – If you think it would be better to have your brochure on a website (for 
better viewing/downloading), the URL giver script can be used to link to the 
website/file.  

Opening Brochures 
1. Right click on the brochure and ‘buy’ it, placing it in your Inventory 

2. Open your Inventory, locate it (should be in Recent Items if it’s just been 
purchased) 

posters 

givers 

URL giver 
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3. Have a look at the items in your inventory (see below) 

 
 
If it’s a texture, you can double click the 
texture to view it 
 
Note: to view the brochure texture more 
closely you can either ‘zoom in’ on it or 
extend it by clicking on the corners of the 
brochure and dragging the sides out further. 
If brochures are too difficult to read, you might consider placing the brochures on a 
wiki or other file repository and linking the brochure to it there (see ‘How to link to 
a URL’). 
 
If it’s an object, you can double click it, but that will attach it to yourself and 
maybe even upside down. You will most likely need to place it somewhere first, 
then zoom in on it. 

Making a brochure 
1. ‘Buy’ the entire brochure kit below. The cube is the ‘kit’ and contains everything 

you can see to its right (ie: wall poster, table poster / giver, folded ‘giver’ brochures 
+ a URL giver). 
  
Note: DO NOT start editing the 
templates you see here. You must 
buy or copy the kit first.  
  
Note: When you ‘buy’ the kit, you 
need to wait until the contents of 
the kit appear in the Buy window 
before you click the blue Buy button. 

texture 
object 
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2. The entire kit will now be in your Inventory 

 
3. Move to a clear work bench and empty the contents of the kit onto the workbench 

in the training room and open your Inventory 

4. Drag and drop the item* you want to work on onto your work bench. The kit 
contains the items shown above. Anything with ‘Customize Me!’ in the filename is 
an object you can customise. 
 
This one is called 
‘DefaultBrochure-
DisplayBoard – 
CustomizeMe!’  This is the 
poster used for display on the 
wall.  
 
 
 
 
 
 
 
This one is the 
‘DefaultBrochure-
DisplayBoard-GIVER!-
CustomizeMe!’ This is used for 
‘giving’ the poster to a ‘buyer’ 
to put in their Inventory to 
read.  
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If your object lands in the wrong spot; 
1. Right click on the object and click Edit; OR, Click on the Build button and in the 

Build window, click on the Edit icon (centre button at top) 

2. Click on the object (the movement or directional arrows should appear if they 
haven’t already) 

3. Use your mouse to click on the directional arrows to move your object in that 
direction (ie: red arrow for left and right movement) 

Prepare your brochure  
NC TAFE VE students have been provided with brochure templates in MS Publisher format.  

These templates are available from your Moodle course, or teacher. You can log into your 
Moodle course with your DEC login.  

Once you have the templates, input your text and graphics into the Publisher template 
and save the file in PNG format ready for upload into the virtual world.  
 
HINT: make the text 20pt + for easier viewing in world. 
 

To upload for PNG file into the virtual world: 
1. Click on File > Upload > Upload Image from the File menu at the top of the 

Imprudence window. 

To assign your graphic file (brochure) to your object in world: 
1. Open your Inventory (go to Recent Items if it’s just been uploaded recently) and 

locate your graphic in the Textures folder. 

2. Open your Build menu and select the Edit icon (centre button along the top of the 
Build window) 

3. Select your object by clicking on it 

4. Drag the texture (brochure you’ve just uploaded into your Inventory) onto the 
object. 
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Rename your texture 

To make it easier to find this object in your Inventory when you have to redisplay it in your 
booth over in the Trade Fair conference centre, rename it to something you will 
remember. 

1. Right click on it and select Edit.  

2. Type the new name in the Name text field on the Edit tab in the Build menu. 

 
Making saleable objects 
For every poster or brochure you create to display at your booth, you will need to create a 
‘giver’ object for visitors to place in their Inventories. 

You can create an object to sell at your booth by either: 

1. Using the customisable ‘shopping bag’ located in the Supply Area 

2. Creating your own object from the Build menu 

3. Making your brochure ‘saleable’ 

Option 1 – The shopping bag 
1. ‘Buy’ the shopping bag from the supply area (take the shopping bag to the 

workroom to work on it to avoid messing up the Trade Hall area). 

2. Open your Inventory. Go to Recent Items > open the Shopping Bag folder > drag 
and drop the shopping bag item onto the workroom floor. 

3. To turn it around to face you (if necessary), right click on the object & select Edit. 
Hold down Ctrl on your keyboard and when the rotation ‘sphere’ appears, click on 
the relevant directional coloured line and move it around with your mouse. 

 

4. To enlarge it (if necessary), select the object and simulataneously hold down  Ctrl-
Shift on your keyboard. When the resize toggles appear, drag out with your mouse. 
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5. Go to your Moodle course and download one of the Shopping Bag templates (or 
see your teacher) 

6. Create your logo, text + logo, image or text + image in the PPT or PSD template 
(using whatever program you prefer to use, PowerPoint or PhotoShop). Save as 
.png or .jpg. 

7. Upload the graphic into your Inventory (File > Upload > Upload Image). 

8. Go to Inventory > Recent Items > Textures & drag and drop the graphic onto the 
front of the shopping bag (where indicated/ onto the label) or go into the texture 
editing area on the Build menu > Edit tab > Texture tab. 

9. Rename your item - in the Build menu, on the Edit > General tab > type in the 
name you want for the item (along with other relevant detials) 

10. Make the object ‘saleable’ – still in the Build menu, set the object ‘For Sale’ at $0 
and make selections for how it can be bought and ‘Next owner’ settings. 

 
Note: You can sell the original (meaning you will no longer have it on your stall), 
you can sell a copy (which means you can keep selling it from your stall) or you can 
just sell the contents of your bag. 

11. Choose how you want people to buy the objec. E.g. Buy object when left clicked 
(this will result in the opening of the box listing contents, users will still need to 
click the buy button) 

 
Note: If you leave the default, a user will need to right-click the object to see the 
Buy option (which is an extra click on top of the two clicks above) 

12. Put the item back in your Inventory – right click on the object and select ‘Take’. 
Now you can take it back to your Trade Show booth & place it in your display. 
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Option 2 – Create your own saleable object 
1. In the workroom, open the Build menu (button at bottom of screen) 

2. Select the ‘Create’ icon button at the top of the Build menu 

 

3. Select the cube shape and click somewhere near your avatar in world (not too close 
or you’ll end up wearing it! – if you do, right click on it, More > Detach) 

4. Resize it to make it easier to work on – select the object, hold down Ctrl-Shift 
simulataneously on your keyboard & use your left mouse to drag out the square 
toggles. 

5. Drag & drop any graphics onto the surfaces of the object from the textures folder in 
your Inventory. To turn your object around as you work on each side, select the 
object & click Ctrl on your keyboard, using your left mouse on the relevant 
rotational coloured line to spin it around.  

 

6. Rename the object in the Build menu under the General tab and other options/ 
settings you wish to apply. 
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7. Make the object ‘saleable’ –in the Build menu, General tab set the object ‘For Sale’ 
and make selections for type of sale and ‘Next owner’ settings. 

 

8. Place the object in your Inventory - right click on the object & select ‘Take’. 

9. Make your way to the Trade Hall area and place it in your booth. 

Making your brochure ‘saleable’ 
1. Find the brochure you created earlier in your inventory 

2. Right click and select ‘Properties’ 

 
3. Click the ‘For Sale’ option, whether you want to sell the original item or a copy of it 

and set a price (for the Trade Fair, we will set it as $0). 
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Buying and selling 

How buying and selling works 
Buyers can transfer one token from their Inventory to a ‘Tokens Collection Box’ at a booth 
for each purchase.  

At the time of purchase, ONE team member at the booth will collate the purchase 
information on the spreadsheet. Booth members may need to ask buyers for information 
about which VE they are from and other relevant details as per the spreadsheet headings. 

What sellers will need 
 At your booth you will need a ‘Token Collector’. The Red and Blue one will give 

buyers instructions when the ‘Touch’ it. You can buy one of these in the Supply 
Room or NCTAFE training center. 

 
 A spreadsheet to record your transactions on as they occur ‘in world’. (Your 

facilitator will have organised this for you). 

What buyers will need 
  ‘Tokens’. Buyers can collect 5 tokens at any time from any Reception Desk. By 

clicking the ‘Click to get Tokens’ box. 

 
Note: Booth holders may need to instruct buyers to return to the Reception 
Desk to get tokens if they haven’t collected them on arrival (as directed by the 
avatars on the reception desk). Buyers can go back to Reception at any time during 
the Trade Fair to collect more tokens if they wish. 
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Sellers - Setting up the Token Collection Box 
Please note: Only ONE team member at your booth can OWN the ‘Tokens Collection 
Box’ so you will need to determine who that will be. That person will be the team member 
who will ‘buy’ the collection box from the Training Centre and place it in the booth. 

1. Go to the Workroom in the 
Training Centre or Supply Room 
and ‘buy’ a ‘Tokens Collection 
Box’ (right click on it and ‘Buy’). 

*Remember – only one person in 
your team should be doing this. 

 
 

2. Return to the Trade Hall. At your 
booth, open your Inventory 
(Recent Items if you’ve only just 
purchased it) and locate the 
folder containing your Collection 
Box. Open the folder and drag 
and drop the Collection Box 
object onto a surface in your 
booth (preferably somewhere 
easily accessible by buyers).  

 

Buyers - Getting tokens into buyers Inventories 
When buyers click on the ‘Click to get Tokens’ box at one of the reception desks, they will 
be able to buy a collection of 5 tokens (each time they click it). You or your receptionists 
may have to instruct avatars to right click on the Token Giver box in order to ‘buy’ their 
tokens.  

You may also have to instruct the buyer how to open their Inventory, locate their token 
collection, add their name to the token and drag and drop one token onto your Token 
Collector (but more about this below). 
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Buying something 
The instruction on the front of the collection ‘machine’ when you zoom in on it says ‘Ctrl-
Drag your token onto the tube’. 

 
Once a buyer has placed one of your saleable items in their Inventory (or have perhaps 
chosen to ‘wear it’ on their person), they need to pay for it. 

You will need to instruct your visitor to: 

1. Open their Inventory and locate their Box of Tokens for buyers folder (probably in 
Recent Items) 

2. Click to open the folder, right click a token and choose Rename, replace the [your 
name], with their name so you will know who the tokens are from. 

3. Hold down Ctrl on your keyboard and left click & drag the token onto the 
Collection machine’s tube. If it lands on top, right click and select Take. Then try 
again. The machine must glow read to accept the token (see screen shot below). 

 

4. The message’Thanks! Your payment has been recorded’ will appear in the text chat 
telling the booth holder that the token has been accepted. If you miss that 
message you can open Local Chat to see all messages. 
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Checking the contents of the token collector 
The owner of the Token Collector machine can check how many tokens are in there by 
right clicking on the collection machine, Edit > Contents tab. The tokens will show up in 
the Contents list. 

Difficulties handing over tokens 
If your customer has trouble placing their token in the token collector, instruct them to 
open their Inventory, locate their tokens folder, and drag and drop their token on to your 
avatar. 

Reloading the screen when textures stop loading 
Click Ctrl-Alt-D then Ctrl-Alt-R on your keyboard. 
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